Fangs for Firefox 1.5 released

Version 0.9.9 adds support for Firefox 1.5. Read more for the details.

I finally managed to get some spare time to update and re-package Fangs to work with Firefox 1.5. If you feel that Fangs is useful for you, please do not hesitate to check out some of the ads that appear on this page.

The new version can be downloaded from the Sourceforge project page.

Please note that you manually have to uninstall the previous version and install the new version from your local disk.

Update: If you didn’t have Fangs installed earlier you will not see any output until you add the following preferences strings:

  • extensions.fangs.output.defaultlang, with the value “en” (remove quotes).
  • extensions.fangs.output.style, with the value “default” (remove quotes).

To edit Firefox preferences type about:config into the browser address bar and press enter.

Update 2:There is also a version for Firefox 2 at the Sourceforge download page. In the future I won’t be writing a blog post for every new Fangs release.

Comments

  1. Rob says at 2006-02-22 02:02:

    I just discovered Fangs a few hours ago and was saddened to see there wasn’t a Firefox 1.5 version… and now, lo and behold, one has been created while I’ve been away!

    I’m off to install now. Thanks in advance for all your hard work.

  2. Justin says at 2006-02-22 21:02:

    Excellent News! Just curious if you’re going to submit the update to addons.mozilla.org?

  3. Peter says at 2006-02-23 08:02:

    Justin: I tried that before, but it took ages for them to update versions so until I have more time it will reside at SourceForge.

  4. Jens Wedin says at 2006-02-24 09:02:

    THANK YOU, I have missed fangs for some time now. I did some ad-clicking to help you out.

  5. Peter says at 2006-02-24 09:02:

    _Jens:__ Thank you.

    I have also created an initial version of the update.rdf file. You should now be able to update fangs through the regular “right-click/update…” functionality. Right now, this will install version 1.0.0 which contains a fix for the missing preferences.

  6. Chris says at 2006-06-08 16:06:

    Is there anything strange with loading 0.9.9 on firefox 1.5.0.4? I can’t seem to get it to go. I’ve had a previous version OK.

  7. chris says at 2006-06-08 21:06:

    I’ve now been able to load fangs 0.9.9 :-). The problem was another extension that saves session information like opera does (now uninstalled). I think it was session saver 2.

  8. Will Olbrys says at 2006-06-28 22:06:

    I’ve been looking for an updated fangs! I just installed it but I’m getting the following error:

    Error: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) nsIPrefBranch.getComplexValue Source file: chrome://fangs/content/prefutils.js Line: 50

    For reference I have the following extensions installed:

    View Source Chart: 2.0.02 Tabbrowser Preferences: 1.2.8.9 Gmail Manager: 0.4.3.6 Open Source in Tab: 1.5 Console2: 0.3.5 IE Tab: 1.0.9.5 Web Developer: 1.0.2 Add N Edit Cookies: 0.2.1.0 Hypertext DOM Browser: 1.0.2 Javascript Debugger: 0.9.87 DOM Inspector: 1.8.0.4 View Formatted Source: 0.9.4.6 Fangs: 0.9.9

    I’m sorry if thats more than you need, or if anyone’s reading this. I will try to figure it out and post any solution here. Hopefully at the very least it will help someone else in the future.

    p.s. I clicked on a bunch of ads ;)

  9. Peter Krantz says at 2006-06-29 13:06:

    Will: Run auto-update for Fangs if you are using 0.9.9. This will install version 1.0 which corrects a bug related to a missing preferences setting.

  10. Will says at 2006-07-06 17:07:

    Thanks for your help Peter! Works great!

  11. federico says at 2006-11-02 12:11:

    i’m sorry… i just installed fangs, but it doesn’t seem to work… I am running firefox 1.5… where do i have to add the preferences strings you wrote about?

    thanks, federico

  12. federico says at 2006-11-02 12:11:

    ehhe… sorry, i am so stupid! :D found it!… it’s a great extension!!

    may i translate it to italian?

  13. Ali says at 2006-12-14 17:12:

    I was getting no output and couldn’t find where to set these preference strings.

    I got it working by going to settings and changing the two settings to something other than default and english, OKing that and then going back to settings and changing them back to default and english. This seemed to register the settings correctly.

  14. Leyton Jay says at 2007-07-02 13:07:

    Oh no! I heard about Fangs a mere ten minutes after updating to FireFox 2.0 and they aren’t yet compatible.

    Any idea when there’ll be a 2.0 compatible update?

  15. Alex says at 2007-07-13 23:07:

    Great extension, but may I ask if you plan to support Firefox 2+ ?

  16. name says at 2008-02-03 06:02:

    That link for Fangs for Firefox 2 doesn’t work. Any way to find the download page? I wish I could download it automagically from the Firefox addon updates.

  17. peter.krantz says at 2008-02-03 10:02:

    @name: I justed tried it and the link works for me?

Leave a comment

You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Peter Krantz, peter.krantz@giraffe.gmail.com (remove giraffe).